How To Fix The Requested Security Protocol Is Not Supported.

How To Fix The Requested Security Protocol Is Not Supported.

 

The error message indicated that the TLS security protocol is not supported.

Many API servers nowadays required at least TLS version 1.2 for a client to establish a connection to their servers.

Windows 10 has TLS1.2 default installed so you will not encounter this problem.
For window 7, TLS 1.2 update will get installed by Regular Windows update. But if your system still missing it. You can fix the problem by manually install TLS1.2.
———————–
Windows 7
https://support.microsoft.com/en-us/help/3154518/support-for-tls-system-default-versions-included-in-the-net-framework
—————————————————————
For 32-bit windows 7 and Server 2008 R2
http://download.microsoft.com/download/6/8/0/680ee424-358c-4fdf-a0de-b45dee07b711/windows6.1-kb3154518-x86.msu
For 64-bit windows 7
http://download.microsoft.com/download/6/8/0/680ee424-358c-4fdf-a0de-b45dee07b711/windows6.1-kb3154518-x64.msu
————————————————————–
Windows 8.1 and Windows Server 2012 R2
https://support.microsoft.com/en-us/help/3154520/support-for-tls-system-default-versions-included-in-the-net-framework
For 32-bit
http://download.microsoft.com/download/6/8/0/680ee424-358c-4fdf-a0de-b45dee07b711/windows8.1-kb3154520-x86.msu
For 64-bit
http://download.microsoft.com/download/6/8/0/680ee424-358c-4fdf-a0de-b45dee07b711/windows8.1-kb3154520-x64.msu

Backup link (In case of official link no longer available)

hotfix_kb3154518_kb3154520